Jump to content

Cavy's Quest Alpha Demo 2

   (3 reviews)

1 Screenshot

About This File

Alpha demo of Cavy's Quest - a point-and-click adventure game created using the XCI game engine. The current graphics are placeholders while the final graphics are created for the first beta release of the demo.

Simply load and run XCI.PRG from BASIC, and all controls are done through the mouse.

Premise: You are a guinea pig named Penelope who yearns for something more than a life in a cage. Explore your environment and solve puzzles to make your dreams of freedom come true.

What's New in Version Alpha Demo   See changelog


No changelog available for this version.




  • Like 3

User Feedback

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.




Great start to an original point-and-click adventure.  I enjoyed the mechanics, the characters, and the aesthetic.  Good stuff.  Looking forward to future versions.

  • Thanks 1
Link to review


My little girl and I had great fun playing this game, she loves hamsters and kept taking over until she got stuck and then Daddy had to come back to help. Between us we got to the end - love the quirkiness and the twist with the dog, we were terrified he was going to eat us! Looking forward to the next bit!

  • Thanks 1
Link to review

· Edited by Vos


My comments are regarding the version of the game uploaded today on Aug 26, 2020.

This is a great start. I got stuck in the scene with the hay until I read the help about controls and used the hidden control bar. Later, when I escaped the cage, it gave me a thrill of success, which I don't usually feel from games in general anymore. This is transporting me back to a simpler time. 🙂

The cavies are cute and their names made me smirk, especially Winifred. The music is soothing.

Having said that, I'm currently stuck in the scene with the table that has the dog food and water. Nothing I click on seems to do anything, even using all the actions in the hidden control bar. Can't even back-out of the scene -- I'm a prisoner there. Since this is labeled an alpha version, I don't know if it's possible for a player to get farther than this or not.

Back in the '80s or '90s, I gave up on these point-n-click adventures because it became too frustrating when I had no clue what to do next, and would spend hours trying a million things that didn't work. As simple as your game is, perhaps it could still benefit from a hint button in the top menu bar, that gives advice based on what scene the person is in... even when you (as the creator) think it's obvious.

As for me, I'm new to X16. Downloaded the emulator just today.


EDIT: You asked if I tried mousing over the table top. Prior to your message, I had tried clicking on the 3 boards that are in the center and toward the top of the table, which produced no result, thus I concluded that clicking on the table top does nothing. After your message, I noticed hovering the mouse pointer over certain boards of the table changes the pointer style. Then I removed the boards but still couldn't solve the puzzle. Found your YouTube video and then did what you showed, and that worked. To me, that's as random as can be, because a cavey would never be capable of doing those manipulations. Well, that's why I am bad at point-n-click games. What made more sense to me to try was to lure the goat over to the food dishes by "talk"-ing (chortling) at the food. And, bump the table legs to tip the containers over.

Response from the author:

Did you try mousing over the table top?

  • Like 1
Link to review
  • Create New...

Important Information

Please review our Terms of Use