Jump to content
  • 0

triggering screen 0, from "c"


CursorKeys
 Share

Question

Hi!

I am working on a little project in screen mode 0.

I can set the screen mode in basic. I can also set it in c.

But when I set it in c, I get incorrect scrolling.  It seems the scroll routing still thinks the screen is 60 characters high.  I can't find it in the manual. (I probably put my blind glasses on :))


Scrolling is done like this. Print lots of character until the lower end of screen is reached, will trigger scrolling. It's rough, but it works.


The screen setting is basically like this:

  *vera_video = 0x20 | 0x10 | *vera_video;
  *vera_hscale = 0x40;
  *vera_vscale = 0x40;
  *vl1_cfg = 96;
  *vl1_map = 0x00;

What am I missing?   I tried checking vera registers after doing a "manual" screen command, and the only thing I came to is the patter 0110 in the mapwidth, map heigh sections of the L1_CONFIG register. (hence    *vl1_cfg = 96; )

Thanks
CC

Edited by CursorKeys
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

Please review our Terms of Use