Jump to content
Uberlinc

Basic file loads

Recommended Posts

Hi,

This might seem like a silly question, and I've searched many websites (including YouTube etc) to find the answer but I've found no clear, simple answer.

Apologies if this has been asked before.

I have the X16 emulator installed.

I downloaded the "Invaderz" program.

So, according to standard Commodore commands, you type: LOAD"PROGRAMNAME.PRG"

However, it can't seem to find it.

I have my emulator sitting under C:\Program Files.

Where is the best place to place it?
Where is the best place to keep your stash of programs relative to the emulator?

When you type "LOAD", how do you specify relative location of the program file?

I even tried placing a copy of "INVADERZ.PRG" into the emulator directory itself.

 

Is there a Dummies' Guide explaining this?

Can anyone point me to this?

Thanks.

 

 

  • Like 1

Share this post


Link to post
Share on other sites

You need to add the emulator executable directory to your path, then you can call it anywhere. Go into your Settings and search for "Environment Variables". In there is the PATH variable, and you can just add that directory to the list that comes up.

Share this post


Link to post
Share on other sites

I am using Windows 10 Pro, I have the x16 Emulator in a folder at C:\x16, and I have game files in a folder at C:\x16\games. I have don't have any past experience with a C64 or with the x16 Emulator. I have gotten some games to load into x16, such as Crazy Snakes, but I have not been able to get Chase Vault to load. Could I get a newbie walkthrough on how to get Chase Vault to load in the x16 Emulator? Thanks

Edited by William

Share this post


Link to post
Share on other sites
8 hours ago, William said:

I am using Windows 10 Pro, I have the x16 Emulator in a folder at C:\x16, and I have game files in a folder at C:\x16\games. I have don't have any past experience with a C64 or with the x16 Emulator. I have gotten some games to load into x16, such as Crazy Snakes, but I have not been able to get Chase Vault to load. Could I get a newbie walkthrough on how to get Chase Vault to load in the x16 Emulator? Thanks

If you download the ZIP file from here, or get the release build from GitHub, just make sure that CHASVALT.PRG and all the .BIN files are in the same directory, then launch the emulator from that very directory. To make it run immediately, you can just do that from the command line:

x16emu -prg CHASVALT.PRG -run

But you could just run the emulator without argument, and just load and run it from inside the emulator:

LOAD"CHASVALT.PRG"

RUN

All of this guidance is also available, including a list of all the .BIN files in the repo's README: https://github.com/SlithyMatt/x16-chasevault

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please review our Terms of Use